www.fltk.net > uBuntu AptituDE不能安装依赖包

uBuntu AptituDE不能安装依赖包

源版本不对。如果删的话还会提示这个,一直提示到你把系统删崩了

但是如图中所示,这次不行,为什么呢?因为一般而言安装制定版本的软件所对应的问题是软件版本过高的的问题.但是在这里并不是这样,而是因为安装这个软件还有很多的其他依赖这里无法提供. 这个时候就要轮到下面的这种方法了. 那就是使用aptitude来代...

建议把已安装的卸载了 或者用aptitude 解决 比apt-get更强

两者的区别是dpkg绕过apt包管理数据库对软件包进行操作,所以你用dpkg安装过的软件包用apt可以再安装一遍,系统不知道之前安装过了,将会覆盖之前dpkg的安装。 1、dpkg是用来安装.deb文件,但不会解决模块的依赖关系,且不会关心ubuntu的软件仓库...

更新一下源,再用其他途径安装试试,比如软件中心,新立得等

最近在使用Puppet快速部署Openstack,看到一些没见过的工具,例如aptitude,在Ubuntu上有强大的apt-get为什么还要用这个呢。本文转自:http://hi.baidu.com/52safe/blog/item/c17891ff02201653d6887d96.html 起初GNU/Linux系统中只有.tar.gz。用...

会从软件仓库中下载对应的deb包(包括依赖包)到本地,下载完成之后自动解包安装

执行一下这个之后再试试: sudo rm /var/lib/apt/lists/* -vf

下面将要介绍的所有命令都需要sudo!使用时请将“packagename”和“string”替换成您想要安装或者查找的程序。 * apt-get update——在修改/etc/apt/sources.list或者/etc/apt/preferences之後运行该命令。此外您需要定期运行这一命令以确保您的软件包...

网站地图

All rights reserved Powered by www.fltk.net

copyright ©right 2010-2021。
www.fltk.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com